Skip to main content

SharePoint 2013 - Newsfeed and Share

New Team Site on my new SharePoint 2013 installation is just amazing.

One of the good new features I like is Newsfeed:


So I wanted to add a picture and some message:


Chosen the picture file and posted:

My post appeared on the newsfeed:

I looked into the Site Contents to see where those posts are stored and found the list called MicroFeed:


The content of this list are items with the metadata values related to the posts:


This is one item:


 As far as I see the image is stored as an attachment to the list:
Then I decided to share the site with Consulting Services department people.
Clicked the Share button at the top right corner of the page and got a dialog box.
When I started typing I have got the people list dynamically shown and selected the person I need:


Selected the level of permissions:




and hit shared:



Then I logged in as a Consultant:

I saw the post on the Newsfeed, Liked it and wrote a comment:

The comment appeared with the status that I liked that:

Then I wrote some work-related posts to the feed:

and decided to upload a document and refer to it from one of my posts.

So I copied the link to uploaded file and pasted it into the new post. SharePoint automatically offered me to format the link:


Good work:

Comments

Popular posts from this blog

Setting up External Content Type for SQL Server database using SQL Server authentication - SharePoint 2010 Foundation

This post is a follow up on the issues that I have got setting up External Content Type (ECT) on SharePoint 2010 Foundation that was going to connect to remote SQL Server database for information. I cannot use my SharePoint user accounts to access SQL Server.

According to the information I have discovered ECT and Business Connectivity Services are available in the SharePoint 2010 Foundation, but there are some issues if you want to use authentication methods in your external connections that are different from Windows Identity or Current User Identity. This is because there is no Secure Store Service in SharePoint 2010 Foundation which serves as an impersonation hub and is only available in SharePoint 2010 Server edition.
The issues are coming from the fact that you can actually create ECT in SharePoint Designer 2010 providing just Secure Store ID and system would ask you for credentials and here you go, but when you try to use your ECT in External Lists or as a lookup columns you wou…

SharePoint 2013 - Setting Up External Content Type

There were earlier posts where we discussed External Content Types setup for SharePoint 2010:

Setting up External Content Type for SQL Server database using SQL Server authentication - SharePoint 2010 Foundation

External Content Types - Reload - Setting up for SQL Server database using SQL Server authentication - SharePoint 2010 Server

This one is about creating connection to the custom SQL Server database (External System) in SharePoint 2013.

1. Create Secure Store Service Target Application

1.1. Go to Central Administration -> Manage Service Applications -> Secure Store Service Application. Click "Generate New Key" if required:


1.2. Provide Pass Phrase:

1.3. Create "New" to create new Target Application:


1.4. Provide the name and other parameters and click "Next":

Note: It's good idea to specify "Group" for Target Application Type. In that case you would be able to manage access to the external data using Active Directory groups rather …

SharePoint 2010 Search Issue - FQDN Crawl

I have recently set up a standalone SharePoint 2010 environment.

The Web application was created with host header and the site collection is accessible from the client machines, but not internally. That was because of using FQDN to access the Web site.

The error when I tried to access site internally was similar to the one described here:

You receive error 401.1 when you browse a Web site that uses Integrated Authentication and is hosted on IIS 5.1 or a later version

And the search returned the following error in the Event Log:

"The start address cannot be crawled.

Context: Application 'Search_Service_Application', Catalog 'Portal_Content'

Details: This item could not be crawled because the crawler could not connect to the repository."

One of the suggestions was to disable the loopback check, but that would compromise the Web server.

So what I have done was:

1. Added a binding to my IIS Web site for a different port. Let's say my Web server name is win-v7m…